[OpenSIPS-Devel] [OpenSIPS/opensips] 980c33: httpd: fix the misspelled access handler callback ...
Bogdan Andrei IANCU
noreply at github.com
Thu Sep 10 12:57:53 UTC 2026
Branch: refs/heads/master
Home: https://github.com/OpenSIPS/opensips
Commit: 980c3306719678156dde90731e275458da3f7f45
https://github.com/OpenSIPS/opensips/commit/980c3306719678156dde90731e275458da3f7f45
Author: Denys Ivonenko <denys.i at didww.com>
Date: 2026-09-08 (Tue, 08 Sep 2026)
Changed paths:
M modules/httpd/README.md
M modules/httpd/httpd.c
M modules/httpd/httpd_load.h
Log Message:
-----------
httpd: fix the misspelled access handler callback typedef
httpd_acces_handler_cb has been missing an "s" since the module was
added in 9e86d39d9 (2012). Rename it to httpd_access_handler_cb, and
fix the same word in the error message next to the check that uses it.
The typedef is compile-time only and no module outside httpd names it -
the five consumers pass their callbacks through httpd_api.register_httpdcb
- so the rename changes no exported symbol and no ABI. No compatibility
define is kept, following 36a09ee7ab, which renamed the C variable
outright and kept the old spelling only for the script-facing modparam.
While here, two long-standing defects in the same declaration:
- httpd_load.h declared "int register_httpdcb(...)", a function that
has never existed: the implementation has been httpd_register_httpdcb
since 2012, reached through the api struct. Nothing could link
against the declaration, so it is removed rather than corrected.
- the Developer Guide documented that dead five-parameter prototype.
02638044d (2013) added "enum HTTPD_CONTENT_TYPE type" to the
register_httpdcb_f pointer that modules actually call, without
updating either the prototype or the page. The parameter is now
documented in its real position, between f2 and f3.
Commit: 61433be15cf23f9af21badc7d15d9168d612e28a
https://github.com/OpenSIPS/opensips/commit/61433be15cf23f9af21badc7d15d9168d612e28a
Author: Bogdan Andrei IANCU <bogdan at opensips.org>
Date: 2026-09-10 (Thu, 10 Sep 2026)
Changed paths:
M modules/httpd/README.md
M modules/httpd/httpd.c
M modules/httpd/httpd_load.h
Log Message:
-----------
Merge pull request #4247 from denys-i-didww/fix/httpd-acces-handler-cb-typo
httpd: fix the misspelled access handler callback typedef
Compare: https://github.com/OpenSIPS/opensips/compare/08e7f1c37aff...61433be15cf2
To unsubscribe from these emails, change your notification settings at https://github.com/OpenSIPS/opensips/settings/notifications
More information about the Devel
mailing list